Nginx任意代码执行漏洞(CVE-2021-23017)

发布时间 2021-05-27

0x00 漏洞概述

CVE  ID

CVE-2021-23017

时    间

2021-05-27

类   型

代码执行

等    级

高危

远程利用

影响范围

Nginx 0.6.18 - 1.20.0

PoC/EXP

未公开

在野利用

 

0x01 漏洞详情

image.png

Nginx是一个高性能的HTTP和反向代理web服务器,同时也提供了IMAP/POP3/SMTP服务,由于其具有许多优越的特性,导致在全球范围内被广泛使用。

2021年05月25日,Nginx官方发布安全公告,公开了Nginx DNS Resolver中的一个任意代码执行漏洞(CVE-2021-23017)。

由于Nginx在处理DNS响应时存在安全问题,当在配置文件中使用 “resolver ”指令时,远程攻击者可以通过伪造来自DNS服务器的UDP数据包,构造DNS响应造成1-byte内存覆盖,从而导致拒绝服务或任意代码执行。

该漏洞仅在配置了一个或多个“resolver”指令的情况下存在,而默认情况下没有配置。

 

0x02 处置建议

目前该漏洞已在以下版本中修复,建议尽快进行升级更新:

NGINX Open Source 1.20.1 (stable)

NGINX Open Source 1.21.0 (mainline)

NGINX Plus R23 P1

NGINX Plus R24 P1

以下版本的NGINX Ingress Controller包括NGINX Open Source和NGINX Plus的修复程序版本:

NGINX Ingress Controller 1.11.2 – NGINX Plus R23 P1

NGINX Ingress Controller 1.11.3 – NGINX Open Source 1.21.0 和NGINX Plus R23 P1

 

下载链接:

http://nginx.org/en/download.html

补丁链接:

http://nginx.org/download/patch.2021.resolver.txt

 

0x03 参考链接

http://mailman.nginx.org/pipermail/nginx-announce/2021/000300.html

https://www.nginx.com/blog/updating-nginx-dns-resolver-vulnerability-cve-2021-23017/

https://support.f5.com/csp/article/K12331123

 

0x04 时间线

2021-05-25  Nginx发布安全公告

2021-05-27  VSRC发布安全通告

 

0x05 附录

 

CVSS评分标准官网:http://www.first.org/cvss/

image.png